Differences between Linux and Solaris Command

Linux command
Solaris similar command
Comments
top
prstat
You can compile top on Solaris, but you can't rely on it's accuracy
free
vmstat

cat /proc/meminfo
prtconf | grep Memory

cat /proc/cpuinfo
psrinfo -v
you can also use prtconf
netstat -p
lsof -i
lsof is not a default command. You need the package
uname -a
isainfo -b
to determine how many bits your os is
java -d64
java -d64
Start java with a default of 64 bit. Linux seems to do this by default though.
cat /etc/redhat-release
cat /etc/release

sysdef
sysdef holds a lot of system info including kernel tunables
lsmod
modinfo

strace
truss

Another matrix

RHEL
Solaris
Shutdown
shutdown -h now (or) poweroff
shutdown -y -g0 -i5 (or) init 5
reboot
reboot (or) shutdown -y -g0 -i6 (or) init 6
halt
halt
Kernel
/sbin/lsmod
modinfo
/sbin/insmod
modload
/sbin/rmmod
modunload
scanpci
/usr/X11/bin/scanpci (or) prtconf -v
Printing
lp (or) lpr
lp (or /usr/ucb/lpr)
lpstat (or) lpq
lpstat (or /usr/ucb/lpq)
Services
/sbin/service --status-all
svcs -a
/sbin/service sendmail stop
svcadm disable sendmail
/sbin/service sendmail start
svcadm enable sendmail
/sbin/service sendmail status
svcs sendmail
/sbin/chkconfig --list
svcs -a
/sbin/chkconfig --add /etc/rc3.d/f00
svccfg import f00.xml
/sbin/chkconfig sendmail on
svcadm enable sendmail
Monitoring
top
prstat
cat /proc/cpuinfo
psrinfo -v
cat /proc/meminfo
prtconf
NFS
exportfs
exportfs (or) share
(edit /etc/exports)
share /home (or) zfs sharenfs=on
(edit /etc/exports) unshare /home (or) zfs sharenfs=off
Networking
/sbin/mii-tool
ndd (or) /sbin/dladm show-dev
ifconfig
ifconfig -a
/sbin/ethtool
ndd
/sbin/dhclient
dhcpagent
iptables
ipfilter
Storage
fdisk
fdisk (and) format
parted
format
mkfs -t ext3 /dev/hda1
mkfs -F ufs /dev/rdsk/c0t0d0s0 (or) newfs /dev/rdsk/c0t0d0s0
cdrecord dev=2,0 f00.iso cdrw -i f00.iso
tar xfvj f00.tar.bz2
gtar xfvj f00.tar.bz2
lvm/pv*/lv*/vg*
meta*
Dev
(edit /etc/ld.so.conf)
crle
gcc
/opt/csw/bin/gcc
ld
/usr/ccs/bin/ld